Exchange 2016 Installation schlägt fehl bei Schritt 11

Der Fehler tritt auf wenn man Exchange 2016 auf Windows 2016 aktualisiert und ist sehr unglücklich, da die Dienste bei Schritt 11 gestartet werden und nicht gestartet werden können. Diese sind noch deaktiviert.

Die Fehlermeldung aus dem Log lautet:

Der Dienst „Microsoft Exchange-Diensthost (MSExchangeServiceHost)“ kann aufgrund des folgenden Fehlers nicht gestartet werden: Der Dienst MSExchangeServiceHost kann nicht auf dem Computer . gestartet werden

Das ist total nichtsagend.

Man kann die Dienste manuell auf Automatisch umstellen und diese starten dann auch, aber ECP und OWA funktionieren nicht.

Hier müssen auf dem Server die Requisites neu installiert werden.

  1. dot Net Framework 4.8
  2. Visual c++ Requisites 2012
    https://www.microsoft.com/download/details.aspx?id=30679
  3. Visual c++ Requisites 2013
    https://support.microsoft.com/help/4032938
  4. Microsoft Unified Communications Managed API 4.0, Core Runtime 64-bit
    https://www.microsoft.com/download/details.aspx?id=34992

Danach die Installation neu starten

Sollte der Fehler nach wie vor auftreten, macht es Sinn die Dienste auf Automatisch zu halten. Dazu eine Powershell starten folgenden Befehl bis Ende der Installation laufen zu lassen.
Achtung: der Microsoft Filterdienst wird dabei nicht berücksichtigt, muss aber auch wieder auf „Automatsich“ gestellt werden.

While (1 -le 2) { Sleep 1 ; Get-Service | Where { $_.DisplayName -Like ‘Microsoft Exchange*’ } | Set-Service –StartupType ‘Automatic’ }

admin has written 95 articles